Введение

Данное Руководство описывает назначение, установку, принципы построения и способы применения программно-аппаратного комплекса Unit Voice Mail, предназначенного для организации системы голосовой почты абонентов телефонной сети.

Будет рассказано как установить пакет, подключить и настроить линии связи с АТС, создать и запустить задачу, обработать и вывести результаты обзвона абонентов.

В документе представлено описание версии 1.0. Последние изменения, не нашедшие своего отражения в Руководстве и не выходящие за рамки текущей версии, оформляются отдельным приложением.


Назначение

Программно-аппаратный комплекс Unit Voice Mail разработан и применяется для организации службы голосовой почты. Подписчиками этой службы являются абоненты телефонной сети.

Служба голосовой почты предназначена для посылки голосовых сообщений ее абонентам и позволяет:

· записывать голосовые сообщения в личный почтовый ящик абонента

· получать абоненту доступ к своему почтовому ящику по паролю

· управлять абоненту своим личным почтовым ящиком с телефонного аппарата

· посылать подписчику уведомление о поступивших новых сообщениях в его почтовый ящик по телефону и электронной почте

· организовывать общие почтовые ящики, применеяемые, например, для сбора донесений от диспетчеров, доски объявлений и пр.

Для каждого абонента системы голосовой почты создается личный почтовый ящик, который характеризуется своим номером. По этому номеру другие абоненты телефонной сети могут получить доступ к его ящику для записи в него сообщения. Сам абонент в любое время, позвонив на номер доступа голосовой почты и введя номер ящика и пароль, может получть доступ к своей почте и настройкам почтового ящика.

Хозяин почтового ящика может

· прослушать новые (старые) сообщения

· удалить сообщение или очистить весь ящик

· записать персональное приветствие

· изменить установки уведомления о поступлении новых сообщений (номер телефона, разрешить/запретить уведомления)


Терминология и сокращения

В Руководстве используются следующие принятые термины и понятия. В случаях объяснения пользовательского интерфейса будут применяться устоявшиеся термины среды Windows.

Далее приведен список часто используемых понятий:

Абонент - физическое или юридическое лицо, представленное записью в базе данных и однозначно определяемое каким-либо признаком (например, номером телефона)

АТС - автоматическая телефонная станция

Выходная таблица - таблица с выходными данными по результатам работы комплекса

Голосовая фраза - единица голосовых данных, используемая для построения голосового сценария и характеризующаяся типом, наименованием и записанным на жесткий компьютера файлом с данными в определенном формате (как правило файлы с расширением ".WAV")

ЛВС - локальная вычислительная сеть

Номер - набранная абонентом последовательность цифр (символов) на телефонном аппарате в процессе соединения

ОС - операционная система

Скрипт обработки - набор команд в стиле языка SQL для выборки данных, обработки или просмотра согласно желаемым критериям

СУБД - система управления базами данных

Отчет - выходной документ, в окне Генератора Отчетов и готовый к распечатке

ПО - программное обеспечение

Результирующая таблица - выходная таблица после применения какого-либо запроса или фильтра

Шаблон отчета - служит для подготовки выходных документов со специфическим форматированием данных

Почтовый ящик - выделенное место на жестком диске и совокупность данных, однозначно определяющих владельца и описывающих параметры хранения данных

Почтовое сообщение - совокупность звуковой информации и других данных (номер почтового ящика, дату/время и т.д.), отражающих факт доставки голосового сообщения


Состав комплекса

Комплекс голосовой почты Unit Voice Mail состоит из программной и аппаратной частей.

В качестве аппаратной части используется плата компьютерной телефонии "Ольха-9" или ее "облегченный" вариант - Ольха-10. Эта плата устанавливается в системный блок компьютера в один из PCI-слотов и может обслуживать до 4 потоков E1. В зависимости от требований конкретного приложения плата может иметь такие опции как эхокомпенсация и компрессия звуковых данных.

Для построения системы Unit Bell рекомендуется использовать версию "Ольха-9P/Е/Е1" - платы "Ольха-9P/Е1" с эхокомпенсацией G.165 и компрессией G.71.

Программная часть комплекса включает в себя

· драйверы для платы компьютерной телефонии "Ольха-9"

· тестовую программу для платы "Ольха-9"

· документацию по установке и программированию платы "Ольха-9"

· систему управления базами данных Sybase SQL Anywhere Studio v7.0.3

· базу данных и программные модули комплекса Unit Voice Mail

· руководство пользователя комплекса Unit Voice Mail (настоящий документ)

В информационной базе данных комплекса Unit Voice Mail хранятся данные по функциональным настройкам всего комплекса и каждого из почтовых ящиков. Там же сохраняются результаты работы системы.

По этим результатам впоследствии можно построить необходимые статистические отчеты для анализа трафика и интенсивности использования почтовых ящиков.


Получение справочных сведений

Все справочные сведения в электронном виде собраны в файлах помощи (HTML Help,Win Word). Доступ к этим файлам осуществляется путем нажатия клавиши F1 в режиме работы соответствующего окна либо с помощью соответствующей программы.

Работа с файлом помощи может происходить в трех режимах: поиск необходимых сведений, используя список разделов справки; поиск сведений по списку глав справки; поиск по словам внутри файла помощи.


Системные требования

Для установки и надежного функционирования программно-аппаратного комплекса Unit Voice Mail необходимо выполнить следующие требования к компьютерному и системному программному обеспечению.

Требования к компьютеру

Комплекс устанавливается на любой IBM-совместимый компьютер, имеющий:

· процессор Pentium (Celeron) с внутренней тактовой частотой от 333 МГц и выше
· объем оперативной памяти от 32 Мбайт (64 Мбайт для Windows NT/Win2000)
· жесткий диск объемом 3Гб и выше
· устройство CD-ROM для установки системы
· звуковую карту, микрофон и колонки( наушника) для прослушивания и записи голосовых фраз

Настоятельно рекомендуется подключать компьютер к сети питания через блок бесперебойного питания во избежание сбоев в работе компьютера из-за возможных помех и наводок в сети или неожиданного полного отключения питания.

Требования к операционной системе

Данная версия системы оповещения Unit Bell работает только под управлением операционной системы MS Windows 9x/NT 4.0/Me/2000.

Внимание! Версия Windows 95 должна быть не ниже 4.00.1111. Для того чтобы узнать, какая версия операционной системы установлена на Вашем компьютере, из меню Start Windows запустите Programs > MS-DOS Prompt. В появившемся окне наберите ver и нажмите клавишу Enter.


Установка и запуск комплекса

Программы пакета Unit Voice Mail устанавливаются с помощью утилиты инсталляции. Все необходимые исполняемые файлы, компоненты баз данных и другие необходимые системные файлы по умолчанию полностью содержатся на дистрибутивном диске (CD_ROM).


Установка оборудования и программного обеспечения

Установка оборудования

Для подготовки комплекса Unit Voice Maill к работе в первую очередь необходимо установить в PCI-слот компьютера плату компьютерной телефонии "Ольха-9" и правильно обжать интерфейсный кабель потока E1, соединяющий соответствующее гнездо платы с разъемом на АТС.

Подробное описание этого процесса можно найти в документации на плату "Ольха-9", поставляемой в составе комплекса.

Описание диска

На установочном диске находятся файлы и папки, необходимые для инсталляции. Последние изменения пакета, а также важные замечания по его установке содержатся в файле Readme.txt.

Установка программного обеспечения

Установка программного обеспечения включает в себя несколько этапов:

1. установка драйвера платы компьютерной телефонии "Ольха-9". Этот этап выполняется при определении операционной системой нового устройства - платы "Ольха-9" или при обновлении версии драйвера и осуществляется стандартным для данной процедуры образом. Драйвера находятся в папке Alder9\Drivers установочного диска соответственно каждому типу операционной системы. После завершения установки необходимо перезагрузить операционную систему.

2. копирование документации и тестовой программы для плат "Ольха-9". Необходимые файлы находятся в папках Alder9\DOC и Alder9\COMMON установочного диска.

3. установка системы управления базами данных Sybase SQL Anywhere Studio v7.0.3. Для выполнения этого этапа необходимо запустить программу SETUP.EXE из папки Sybase Anywhere Studio v7.0.1 установочного диска и далее следовать инструкциям программы инсталляции. По завершении установки необходимо перезагрузить операционную систему. Для установки обновлений СУБД до версии 7.0.3 необходимо провести инсталляцию пакета обновлений. Для этого следует запустить программу SETUP.EXE из папки SQL Anywhere 7.0.3 установочного диска и далее следовать инструкциям программы инсталляции. По завершении установки необходимо перезагрузить операционную систему.

4. установка системы оповещения Unit Voice Mail. Этот завершающий этап инициализируется запуском программы SETUP.EXE из папки vMail установочного диска. Мастер инсталляции выполнит все необходимые действия по копированию системных файлов на компьютер пользователя и произведет соответствующие записи в реестр системы.

Все необходимые для работы комплекса Unit Voice Mail программные модули и файлы сохраняются в папке X:\Unitel\vMail (если пользователь не выбрал другое), где X: - имя диска. Ниже приводится перечень и описание файлов пакета:

· vMailSrv.exe - серверный модуль, исполняющий информационные задачи. Это приложение работает в фоновом режиме на основании установленных для исполнения в базе данных задач. Управление почтовыми ящиками и серверным модулем осуществляется с помощью модуля VoiceMail.exe.

· vMailSrv.ini - конфигурационный файл, содержащий настройки, необходимые для работы серверного модуля.

· VoiceMail.exe - диалоговый модуль управления почтовыми ящиками абонентов и другими информационными задачами. Применяется для создания и редактирования учетных записей абонентов голосовой почты, просмотра результатов работы с системой и текущего состояния телефонных линий, построения отчетных документов.

· Connect.ini - конфигурационный файл, содержащий настройки, необходимые для работы управляющего модуля VoiceMail.exe.

· a9r15pp2t.bin (и другие файлы с расширением BIN) - файлы загрузчика для разных типов сигнализаций. Описание файлов можно найти в документации на плату "Ольха-9Р".

· vMailSrv.log - файл журнала, содержащий трассировки работы серверного модуля согласно текущим установкам LOG-файла. Создается в процессе работы комплекса.

· папка SOUND - содержит звуковые файлы (*.WAV), используемые для построения голосового меню задач.

· папка REPORT - содержит шаблоны файлов отчетных документов.

· папка DB - содержит файл базы данных VoiceMail.db и файл параметров запуска сервера БД VoiceMail.cfg.


Настройка и запуск комплекса

После полной установки аппаратной и программной частей комплекс Unit VoiceMail готов к работе. Если при инсталляции были выбраны папки, отличные от предлагаемых по умолчанию, может потребоваться корректировка некоторых параметров в файлах конфигурации (vMailSrv.ini и Connect.ini). Как это сделать объясняется в соответствующих разделах.

Сразу после установки комплекс готов к работе. Для этого необходимо загрузить сервер базы данных и сервер управления комплексом Unit Voice Mail. Соответствующие "иконки" расположены на рабочем столе операционной системы.

Для просмотра состояния задач и их корректировке необходимо загрузить диалоговый модуль управления VoiceMail.exe. Этот модуль может исполняться на любом компьютере локальной вычислительной сети (ЛВС). Для соединения с сервером Unit Voice Mail необходимо в настройках программы ввести верные параметры связи с vMailSrv.

После включения и загрузки компьютера сервер БД и сервер vMailSrv будут запущены автоматически.

Изначально в базе данных нет активных задач и настройки сервера vMailSrv выставлены по умолчанию. Поэтому сразу после завершения установки рекомендуется провести настройку параметров сервера, потоков и тайм-слотов в соответствии с установленной конфигурацией окружения (компьютера и АТС, к которой подключен комплекс Unit Voice Mail). Порядок настройки подробно описан в разделе серверный модуль.

В любое время сценарий запуска программных модулей может быть изменен. Например, если Вам нет необходимости загружать программы при запуске системы удалите соответствующие записи в реестре системы. Для этого загрузите программный модуль REGEDIT.EXE (это можно сделать из меню "ПУСК"->"ВЫПОЛНИТЬ"), перейдите в секцию HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current Version\Run и удалите запись vMailSrv.exe. Теперь для запуска системы оповещения достаточно вручную загрузить на выполнение модуль vMailSrv.exe используя те же "иконки" рабочего стола ОС.


Работа с программным обеспечением

В данном разделе будут рассмотрены вопросы настройки, использования и обслуживания модулей и хранилищ данных, входящих в состав программного обеспечения комплекса Unit Voice Mail.

Все программные модули представляют собой Windows-приложения и имеют многопоточную архитектуру.


Общие положения

Система голосовой почты Unit Voice Mail обеспечивает выполнение следующих основных функций:

· запись голосовых сообщений в почтовый ящик абонента

· доступ к почтовому ящику по телефону, прослушивание и удаление записанных сообщений

· настройка параметров своего почтового ящика абонентом с телефона

· формирование персонального приглашения для каждого ящика

· отправка уведомления о поступлении новых сообщений абоненту по указанному номеру телефона и по электронной почте

Сообщения в системе хранятся в так называемых "почтовых ящиках". Ящики могут быть двух типов - обычные (персональные, приватные) и общие.

Для каждого пользователя системы заводится почтовый ящик обычного типа, в котором хранятся голосовые сообщения, предназначенные для данного пользователя. Запись сообщений в обычный ящик производится любым абонентом, знающим номер ящика. Чтение содержимого ящика и его настройку может производить только его владелец.

Также могут быть созданы общие ящики. Для них недоступны функции настройки параметров по телефону. Чтение и запись сообщений в общие ящики могут выполнять любые пользователи.

Каждый ящик характеризуется следующими основными параметрами:

номер ящика - уникальный номер почтового ящика. Необходим для доступа к ящику всеми пользователями

пароль - пароль для доступа к приватному ящику при прослушивании сообщений и изменении настроек

владелец - текстовая информация, описывающая владельца почтового ящика

частный/общий - признак, определяющий является ли данный ящик частным обычным (частным) или же общим

максимальный размер - устанавливает ограничение на объем записанной в почтовый ящик информации

уведомление по eMail - определяет необходимость уведомления абонента о поступлении новых сообщений по электронной почте и содержит eMail адрес

группа - определяет принадлежность почтового ящика к какой-либо группе. Используется для систематизиции и удобства работы с почтовыми ящиками

открыт/закрыт (заблокирован) - признак блокировки почтового ящика. Для заблокированных ящиков все процедуры дрступа к нему по телефону недоступны

уведомление по телефону - определяет необходимость уведомления абонента о поступлении новых сообщений по телефону и содержит его номер.

Каждое почтовое сообщение характеризуется следующими параметрами:

номер ящика - определяет принадлежность письма к почтовому ящику

дата/время записи сообщения

имя файла с звуковыми данными

размер звукового сообщения

Любой позвонивший по номеру доступа голосовой почты абонент попадает в главное меню, где ему предлагается сделать выбор: оставить сообщение или прослушать сообщения почтового ящика.

Если абонент желает оставить сообщение, то ему необходимо ввести номер почтового ящика и далее, следуя приглашению меню, оставить свое сообщение. Эта функция поступна любому абоненту телефонной сети

Если же позвонивший пользователь системы голосовой почты желает прослушать сообщения почтового ящика, он также обязан ввести номер ящика. Далее, для общего (публичного) ящика доступ открывается для любого пользователя и абонент может прослушать все сообщения, следуя подсказкам меню. Если выбранный почтовый ящик является частным, необходимо будет ввести пароль доступа к ящику.

Подробный алгоритм работы абонента с комплексом голосовой почты находится в файле ALG.DOC в рабочей директории vMail.

Для выполнения комплексом своих функций в состав его программного обеспечения включены два модуля:

· Серверный модуль - основной модуль, обеспечивает работу комплекса в автономном режиме

· Управляющий модуль - применяется оператором для управления работой комплекса, создания и ведения почтовых ящиков, построения и вывода отчетной информации.


Управляющий модуль

Для создания и ведения почтовых ящиков, мониторинга состояния каналов, просмотра результатов работы комплекса и вывода отчетных документов предназначен программный модуль VoiceMail.exe. Внешний вид главного окна программы представлен на рисунке 1.

Рис.1. Главное окно управляющего модуля

Работа с функциями главного окна осуществляется через управляющие компоненты Windows. Это - меню, Toolbar, окна, деревья, списки и т.д. Некоторые окна построены таким образом, что они могут быть "отсоединены" от главного окна и располагаться на экране монитора независимо. К таким окнам можно отнести окно состояния задач, окно состояния потоков и тайм-слотов, окно статистики.

Состав и функции компонентов главного окна будут рассмотрены в следующих разделах.


Меню

Меню предназначено для доступа ко всем функциям управляющего модуля. Главное меню содержит пункты Настройки, Вид и Справка. Через них можно получить доступ к меню следующего уровня.

Пункт меню Настройки объединяет в себе еще три пункта:

· ящики

· группы

· параметры

В меню Ящики собраны пункты доступа к функциям работы с почтовыми ящиками. К этим функциям можно получить доступ из функциональной линейки ToolBar, находясь в окне работы с почтовыми ящиками.

Меню Группы открывает доступ к процедуре работы с группами почтовых ящиков. Каждый почтовый ящик принадлежит какой-либо группе. Это сделано для удобства ведения учетных записей абонентов оператором и возможности группировки данных в отчетных документах.

Меню Параметры содержит окно диалога для ввода и редактирования текущих системных параметром модуля.

Пункт меню Вид предназначен для настройки внешнего вида главного окна и вызова на экран дополнительных окон модуля.

Через пункт меню Справка можно получить доступ к файлу справки по системе Unit Bell и информации о разработчиках и текущей версии системы.


Окно почтовых ящиков

Окно почтовых ящиков предназначено для просмотра текущего состояния, добавления, удаления и редактирования учетных записей почтовых ящиков.

Рис. 2. Окно работы с почтовыми ящиками

Окно почтовых ящиков включает несколько рабочих областей. Инструментальная панель (Tool Bar)

предназначена для быстрого доступа к функциям работы с учетными записями ящиков. Для создания нового ящика достаточно нажать на кнопку [image]. Для редактирования и удаления учетных записей почтовых ящиков служат кнопки [image] и [image] соответственно. Эти функции доступны также и через меню Настройки->Ящики.

Ниже располагаются поля для поиска. Так, при желании можно вывести только почтовые ящики, принадлежащие какой-либо конкретной группе, отсортировать по номеру или вывести определенный ящик, найти нужный ящик по имени его владельца. Для этого необходимо заполнить соответсвующие поля
и нажать [image].

Текущий набор почтовых ящиков, удовлетворящих условиям поиска, отображается в области

Здесь находится информация о типе ящика (частный [image] или общий [image]), номер ящика и имя владельца.

В правой части окна расположена область почтовых сообщений. При выборе курсором конкретного ящика здесь выводится список поступивших в этот ящик сообщений с датой и размером файла звуковых данных.

Любое сообщение из этого списка можно удалить [image] или прослушать [image] через динамики компьютера.


Работа с почтовыми ящиками

При создании нового ящика и редактировании параметров существующего оператор работает с окном, представленным на рисунке 3.

Рис. 3. Окно редактирования параметров почтового ящика

Любой ящик может быть личным или общим. От типа ящика зависит поведение системы в ходе работы абонента с системой по телефону. Так, при прослушивании сообщений для личного ящика необходимо будет ввести пароль. Для общего ящика функции прослушивания почты доступны всем пользователям, даже не являющимися абонентами голосовой почты.

Если ящик заблокирован, то он не может быть доступен пользователям голосовой почты.

Принадлежность почтового ящика к какой-либо группе устанавливается в поле Группа. Группы заводятся в меню Настройки->Группы.

В поле Владелец указывается имя владельца почтового ящика. Это имя в дальнейшем удобно будет использовать в отчетных документах.

В поле Пароль вводится пароль для доступа к ящику. Пароль должен состоять только из цифр.

Поле Размер (Кб) содержит ограничение на общий объем почтовых сообщений ящика в килобайтах. При превышении этого значения ящик блокируется.

Для каждого ящика может быть записано персональное приветствие. Прослушать его можно, нажав кнопку [image]. Записать персональное приветствие можно через меню голосовой почты с телефонного аппарата.

При поступлении новых сообщений в почтовый ящик абоненту система может прислать уведомление об этом событии. Для настройки параметров уведомления предназначены параметры группы Оповещение.

Для уведомления по телефону необходимо установить флаг [image] и ввести номер телефона владельца ящика.

Для уведомления по электонной почте также необходимо установить флаг [image] и задать eMail-адрес. В этом случае абоненту будет доставлено уведомляющее сообщение, параметры которого задаются в файле конфигурации vMailSrv.ini.


Результаты выполнения

В процессе работы комплекса Unit VoiceMail текущая трассировка результатов работы выводится в специальное окно.

Рис. 4. Окно результатов работы

Все записи располагаются в хронометрическом порядке либо по возрастанию, либо по убыванию (задается нажатием на заголовок столбца Дата/время).

Трассировке подлежат следующие действия:

· письмо проиграно

· письмо удалено

· изменен пароль

· записано приветствие

· записано письмо

· уведомление по телефону

· уведомление по eMail

· уведомление по телефону (изменение параметров)

· уведомление по eMail (изменение параметров)

· изменен телефон

Более подробную информацию по ходу и результатам выполнения задачи можно получить, воспользовавшись модулем статистики и построения отчетных документов (см. Отчеты).

Количество записей параметры вывода информации о результатах выполнения задач устанавливаются в через меню Настройки->Параметры или нажатием кнопки [image] на инструментальной панели главного окна модуля (см. Параметры).


Состояние каналов

В процессе работы комплекса в реальном режиме времени можно отслеживать состояния всех установленных в системе потоков E1 и тайм слотов. Эта возможность доступна только в том случае, если установлена связь управляющего модуля с сервером комплекса Unit VoiceMail. Наличие связи с сервером индицируется на инструментальной панели специальной кнопкой. Если связь установлена кнопка имеет вид [image], в противном случае кнопка выглядит как [image] и нажатие на нее запустит процедуру поиска и установления соединения с серверным модулем.

Окно отображения состояния линий может располагаться на экране монитора обособленно, либо входить в состав главного окна. Оператор может сам настроить удобный для него сценарий поведения окна отображения состояния каналов.

Это окно имеет две области. В первой расположено дерево, отображающее наличие в системе плат компьютерной телефонии "Ольха" и установленных на них цифровых потоков E1.

Вторая область содержит информацию о тайм-слотах выбранного для мониторинга потока. Каждый тайм-слот имеет свой номер, он может быть включен или выключен, о чем свидетельствует "лампочка", следующая за номером тайм-слота. Тип тайм-слота отображается пиктограммой:

· для исходящего

· для входящего

· для входяще/входящего

Направление установления соединения также отображается соответствующими пиктограммами:
- для исходящего соединения.

Далее следует номер телефона абонента и наименование исполняемой на данном канале задачи.


Отчеты

Для обработки и анализа результатов работы комплекса, а также построения и выдачи на печать отчетных документов применяется модуль статистки.

Этот модуль встроен внутрь управляющего модуля и может быть вызван на исполнение с помощью пункта меню Вид->Панели->Статистика. Окно модуля статистики может располагаться как обособленно, так и в составе главного окна.

Рис. 5. Окно модуля статистики

С помощью этого модуля можно строить и выводить на печать отчеты на основе подготовленных ранее шаблонов, добавлять новые шаблоны, редактировать или удалять существующие.

Управление модулем статистики осуществляется посредством инструментальной панели
.

- используется для построения и просмотра отчета. Нажав на расположенную справа стрелку можно получить историю работы с модулем.

- служит для вывода отчета на печатающее устройство. Предварительно необходимо установить в системе хотя бы один принтер и назначить его устройством по умолчанию.

- создает новый шаблон и вызывает на исполнение модуль построения отчета.

- используется для редактирования существующего шаблона.

- создает новую папку шаблонов.

- позволяет переименовать существующую папку шаблонов.

- удаляет папку или шаблон.

- импортирует готовые шаблоны из директории шаблонов.

Все шаблоны отчетов могут быть сгруппированы в папки по какому-либо признаку. Для этого с помощью имеющихся инструментальных средств необходимо создать папку и поместить туда шаблоны отчетов.

При поставке комплекса Unit VoiceMail в состав модуля статистики входит несколько общих шаблонов отчетов. Для их редактирования, расширения или создания новых шаблонов пользователь программной системы может самостоятельно освоить принципы построения шаблонов и добавлять их в соответствии со своими потребностями. Руководство пользователя редактором шаблонов отчетов входит в состав стандартной поставки ПО комплекса Unit VoiceMail.


Параметры

Необходимые для работы управляющего модуля значения параметров сведены в окно диалога, который можно вызвать на выполнение посредством меню Настройки->Параметры.

Рис. 6. Настройки управляющего модуля

Секция Журнал обзвона определяет параметры вывода на экран монитора и обновления информации по результатам работы комплекса.

Журнал может обновляться либо по команде от сервера vMailSrv, либо по таймеру. В последнем случае необходимо установить переключатель Таймер и выставить интервал обновления данных (в секундах). Следует помнить, что слишком малый интервал может привести к излишней нагрузке в работе системы, так как модуль будет постоянно опрашивать БД на появление в ней новых записей.

Длина журнала устанавливает количество выводимых на экран записей результатов работы системы. Если нет необходимости не устанавливайте слишком большое значение этого параметра!

Секция Адрес сервера определяет IP-адрес и порт сервера vMailSrv. Если эти параметры заданы верно и сервер загружен на указанном компьютере локальной сети, с ним будет установлена связь.

Секция Путь устанавливает путь к папке, содержащей звуковые файлы, использующиеся при построении голосового сценария.


Серверный модуль

Для непосредственного выполнения функций годосовой почты предназначен серверный модуль vMailSrv.

Этот модуль может быть загружен автоматически вместе со стартом операционной системы или же вручную из каталога, куда он был установлен программой инсталляции. Во время старта модуль проверяет загружен ли сервер БД и, если нет, то загружает его в соответствии со строкой запуска, прописанной в файле конфигурации vMailSrv.ini в секции DbConStr раздела [SYSTEM] (см. Общие).

Далее проверяется присутствие драйвера платы компьютерной телефонии "Ольха-9Р" в системе. При его отсутствии или ошибке при инициализации платы программный модуль прекращает свою работу. Если загрузка платы прошла успешно, далее производится распределение памяти под управляющие структуры и инициализация необходимых параметров согласно значениям, установленным в конфигурационном файле vMailSrv.ini. Подробное описание параметров будет дано ниже.

После загрузки сервер сразу готов к работе - обрабатывать входящие звонки согласно алгоритма голосовой почты.

Свое название "серверный" модуль vMailSrv получил благодаря возможности подключать к себе для управления несколько управляющих модулей VoiceMail (используя IP-протокол) и распределять между ними ресурсы. Таким образом, можно получить доступ к текущему состоянию процесса оповещения из любого места локальной сети, в том числе и через Internet.


Управление

Сразу после запуска серверного модуля в правой нижней части экрана появляется иконка, отображающая процесс запуска сервера.

старт сервера

Если запустить модуль по каким-либо причинам не удастся, программа будет выгружена из памяти, а иконка - удалена из SysTray.
В противном случае иконка примет вид, показанный на рисунке [image]. Это означает, что все ресурсы и службы были запущены и необходимые структуры проинициализированы, после чего можно начинать работу.

В штатном режиме работы серверного модуля он запускается без внешнего интерфейса и не требует какого-либо управления. Всю необходимую для работы информацию модуль берет из базы данных, а стартовые значения параметров - из файла конфигурации vMailSrv.ini.

В процессе работы модуля некоторые значения параметров конфигурации модуля могут быть изменены через специальное окно настройки. Вызвать это окно можно либо дважды "щелкнув" мышью на иконке сервера, либо, нажав на ней правой клавишей и выбрав пункт Свойства. На экран будет выведено окно диалога, показанное на рисунке 7.

Рис.7. Настройка параметров сервера

В данном окне представлены параметры, изменение значений которых может понадобиться в ходе работы сервера, без его полной остановки. В основном это касается установок журнала.

В процессе работы модуля все трассировки могут выводиться на экран и в файл. Соответствующие параметры в секции Направление вывода LOG устанавливают это направление. Следует помнить, что печать данных журнала необходима только в процессе отладки и поиска неисправностей. В штатном режиме работы модуля использовать эту возможность не рекомендуется, так как вывод дополнительного потока данных на экран (консоль) и в файл может приводить к замедлениям и потере эффективности в работе сервера, особенно при значительных размерах LOG-файла. Если Направление вывода LOG установлено "В файл", то будет создан для записи данных файл журнала eBellSrv.log.

Все сообщения имеют три уровня:

1. сообщения

2. предупреждения

3. ошибки

Установка или сброс вывода соответствующей категории выполняется в секции Категория сообщений LOG.

Секция Уровень сообщений LOG позволяет выбрать для вывода сообщения только от определенных объектов модуля. В программе сервера версии 1.0 используются объекты только следующих типов:

· общие - информационные сообщения модуля, ошибки и предупреждения общего характера, не относящиеся конкретно к какому-либо определенному объекту

· сокеты - информация об объектах WinSock

· сетевые клиенты - информация о подключении и обмене данными с управляющими модулями (eBell)

· БД - информация о подключении и сообщениях сервера базы данных

· отладка - внутренние сообщения, отладочная информация. Используется для более подробного мониторинга состояния платы, потоков, линий, задач и т.д.

· устройства - информация от установленных физических устройств (платы, потоки, тайм-слоты)

Таким образом, выбрав необходимый уровень и категорию сообщений можно отследить поведение конкретного объекта, входящего в состав модуля.

Для долговременного мониторинга с возможностью сохранения протокола в файле журнала необходимо выбрать направление записи данных - в файл. Если параметр logAppend файла конфигурации имеет значение YES, то выводимая информация будет добавляться в конец существующего файла журнала, если - NO, то при запуске модуля eBellSrv этот файл будет перезаписан с начала.

Для текущего отображения состояния выбранных для мониторинга объектов можно разрешить вывод данных на экран монитора. С этой целью необходимо установить направление вывода - на экран. После включении данной опции на экране монитора будет создано окно консоли модуля и вся выводимая информация будет доступна для просмотра в этом окне.

Параметр период обновления уведомлений устанавливает период времени в секундах, через который модуль обновляет внутреннюю информацию о наличии новых сообщений, нуждающихся в уведомлении, то есть собщении абоненту о поступлении почты в его ящик.


Настройки

Некоторую часть настроек серверного модуля можно изменять в процессе его работы. Эти изменения вступают в силу немедленно. Об этом было рассказано в предыдущей главе.

Основные настройки загружаются только при старте модуля. Все настройки хранятся в файле vMailSrv.ini, где они сгруппированы по назначению в секции. Секция определяется своим именем, заключенным в скобки, например "[SYSTEM]".

Следом за именем секции располагаются строки параметров. Каждый параметр имеет название, вслед за которым через "=" записывается значение параметра. Например, DbConTimeOut=10.

Если необходимо, после значения параметра или в любом другом месте конфигурационного файла можно расположить комментарии. Комментарий - это строка, начинающаяся с символа ";". Строка комментария модулем не читается и не обрабатывается.

Далее подробно рассмотрим все параметры файла конфигурации серверного модуля.


Общие

Секция [SYSTEM] - общие параметры модуля:

· logMode - определяет направление вывода данных журнала:
· FILE - в файл vMailSrv.log
· CONSOLE - на экран монитора
· ALL = FILE+CONSOLE

· logCatLevel - категории выводимых сообщений:
· MESSAGE- сообщения
· WARNING-предупреждения
· ERROR-ошибки
· ALL = MESSAGE+WARNING+ERROR

· logMesLevel - уровень сообщений объектов модуля:
· STATE - общие/системные сообщения
· IOPORTS - сообщения портов ввода/вывода
· PIPES - сообщения программных каналов
· QUEUES - сообщения очередей
· SOCKS - сообщения WinSock
· CLIENTS - сообщения сетевых клиентов
· SQL - сообщения базы данных
· DEBUG - отладочная информация
· UNITS - сообщения от устройств
· ALL - все вышеперечисленные вместе

· logAppend - флаг, определяющий добавлять данные журнала к существующим (YES) или перезаписывать при каждой новой загрузке модуля (NO)

· DbConStr - определяет строку соединения (запуска) с БД. Описание значений параметров, использующихся в строке DbConStr можно найти в документации на СУБД Sybase SQL Anywhere v 7.0.3, которая находтся в папке с установленной СУБД. Часто используемые параметры следующие:

· AUTOSTOP - определяет, выгружать сервер БД после остановки серверного модуля vMailSrv (YES) или нет (NO)
· UID - имя доступа к базе данных. По умолчанию установлено "DBA". Меняется с помощью утилит СУБД (Sybase Central). При изменении этого значения в базе данных необходимо изменить его и данной строке соответственно.
· PWD - пароль доступа к базе данных. По умолчанию установлен "SQL". Меняется с помощью утилит СУБД (Sybase Central). При изменении этого значения в базе данных необходимо изменить его и данной строке соответственно.
· DBN - имя базы данных (в данном случае vMail)
· ENG - имя сервера базы данных (в данном случае vMail). Вообще под одним сервером (ENG) может быть запущено несколько БД (DBN). В этом случае имя сервера БД (ENG) необязательно будет совпадать с именем БД (DBN).
· LINKS - определяет протокол, через который клиент связывается с сервером БД. Используется в случае, если сервер БД и модуль vMailSrv располагаются на разных компьютерах одной ЛВС. В нашем случае значение параметра должно быть TCPIP.
· START - строка, определяющая команду запуска сервера БД. Используется, если сервер БД и серверный модуль находятся на одном компьютере и сервер БД запускается в момент старта vMailSrv. Пример стартовой строки может быть таким: "C:\sybase\SQL Anywhere 7\win32\dbsrv7.exe @c:\msds\olha\db\vMail.cfg", в файле vMail.cfg содержатся параметры запуска сервера БД.

· DbConTimeOut - промежуток времени (в секундах), в течение которого модуль пытается найти или запустить сервер БД и установить с ним соединение. Если в течение указанного времени связь не была установлена, модуль завершает свое выполнение. В случае, если все параметры доступа к БД настроены верно и все необходимые модули присутствуют, а сервер БД не стартует и, как следствие, не запускается серверный модуль, необходимо увеличить значение этого параметра.

· timeRefresh - параметр период обновления задач устанавливает период времени в минутах, через который модуль обновляет внутреннюю информацию об активной исходящей задаче. То есть, если, например, в ходе выполнения текущей активной задачи модуль проверяет установки других задач в БД и находит, что активной в данный момент стала другая задача, все соединения по текущей задаче разрываются и начинает выполняться новая задача. Изменение значения этого параметра доступно из окна установки серверного модуля.

· MyAON - строка, определяющая номер абонента, инициирующего соединение, то есть номер телефона системы оповещения Unit Bell (информация АОН).

· IPPORT - номер IP-порта, на котором ожидает подключения клиентов серверный модуль.

· NUMWP - максимально возможное количество сетевых клиентов, одновременно подключенных к модулю vMailSrv.

· WAV_DIR - определяет поддиректорию относительно текущей (содержащей модуль vMailSrv), в которой располагаются звуковые файлы.


Платы

Секция [BOARD#n] - параметры платы

Содержит параметры для платы компьютерной телефонии "Ольха-9Р" под номером n.

· LOADER - определяет имя файла загрузчика для конкретной сигнализации. Все потоки одной платы будут использовать одну сигнализацию. Файл должен располагаться относительно папки, в которой записаны программные модули комплекса Unit VoiceMail (обычно это папка C:\UNITEL\VOICEMAIL).


Потоки

Секция [STREAM#n] - параметры потока E1

Содержит параметры потока E1 с номером n соответствующей платы компьютерной телефонии "Ольха-9Р".

· ON - определяет включен поток (ненулевое значение) или нет (значение равно "0"). Значение по умолчанию - 0.

· SYNCHRO_TYPE - определяет тип сверхкадровой синхронизации. Возможные значения 0 -DoubleFrame и 1 - MultiFrame. Значение по умолчанию - 0.

· SYNCHRO_MODE - определяет источник синхронизации звуковых тайм-слотов. Возможные значения: 0 - синхронизация от платы, 1 - от потока. Значение по умолчанию - 0.

· CODE_TYPE - определяет тип линейного кода. Возможные значения: 0 - HDB3, 1 - AMI. Значение по умолчанию - 0.

· DIAL_MODE - определяет режим набора номера. Возможные значения: 0 - блочный и 1 - перекрывающийся (последовательный). В блочном режиме набора номера все цифры сначала накапливаются в блок, а затем сразу высылаются в сигнальном тайм-слоте. В перекрывающемся режиме цифры номера передаются по мере их набора абонентом на телефонном аппарате, то есть по одной. Значение по умолчанию - 0.

· TIME_OUT_OVRLP - определяет длительность ожидания набора номера в перекрывающемся режиме (в млсек). Значение по умолчанию - 2.

· CALLED_DIGITS - определяет количество цифр вызываемого абонента. Для типа сигнализации Е1 (СТС) R1.5 (2ВСК) возможно установка фиксированного количества цифр для вызова абонента. То есть, если абонент наберет меньшее количество цифр на телефонном аппарате, чем установлено при помощи этой функции, то попытка установки соединения производиться не будет. Необходимо помнить, что для СТС R1.5 количество цифр вызываемого абонента, установленное этой функцией, обязательно должно совпадать с количеством цифр, установленного на АТС, с которой соединена плата. В случае, когда количество цифр различается, возможна некорректная работа платы с АТС и АТС с платой. Значение по умолчанию - 7.

· MFR - определяет тип передачи цифр номера для СТС R1.5.Для типа сигнализации Е1 (СТС) R1.5 (2ВСК) возможно два типа передачи цифр вызываемого номера MFR=1 и Decade=0 (импульсный челнок). Необходимо помнить, что для СТС R1.5 тип передачи цифр номера должен совпадать с режимом, установленным на АТС, с которой соединена плата. В случае, когда количество цифр различается, возможна некорректная работа платы с АТС и АТС с платой, и установление соединения станет невозможным. Значение по умолчанию - 1.

· TONE_DUR - длительность тональной посылки MFR в млсек. Это поле действительно, если поле MFR не равно 0. Может принимать значения от 1 до 255. Значение по умолчанию - 50 млсек.

· PAUSE_DUR - длительность паузы между тональными посылками MFR в млсек. Это поле действительно, если поле MFR не равно 0. Может принимать значения от 1 до 255. Значение по умолчанию - 50 млсек.

· DEFCHAN - определяет установки всех тайм-слотов потока E1 по умолчанию.
· Первый параметр в данной строке: тайм-слот включен (1) или выключен (0).
· Второй параметр: тип канала - 0-входяще/исходящий, 1-входящий, 2-исходящий.
· Третий параметр: тип оборудования на данном тайм-слоте 0-неопределенное оборудование, 1-телефон, 2-FAX.

· CHANNEL#n - определяет установки тайм-слота потока E1 с номером n. Если какого-либо тайм-слота значения параметров не установлены, то принимаются значения по умолчанию, заданные в строке DEFCHAN.


Параметры голосовой почты

Секция [VOICE_MAIL] - Параметры голосовой почты

Содержит параметры управления алгоритмом работы голосовой почты:

· voiceTimeOut - тайм-аут ожидания набора абонентом последовательности символов на тастатуре телефонного аппарата. Исчисляется в секундах. Значение по умолчанию - 10 секунд.

· recLimit - ограничение размера звукового файла почтового сообщения (в байтах)

· noticeRefresh - период обновления уведомлений устанавливает период времени в секундах, через который модуль обновляет внутреннюю информацию о наличии новых сообщений, нуждающихся в уведомлении (собщении абоненту о поступлении почты в его ящик). Значение по умолчанию 2 секунды.

· SMTP_ADDR, SMTP_PORT - параметры почтового сервера (адрес и порт), через который отправляются уведомления абоненту о поступлении в его почтовый ящик новых сообщений.

· MAIL_FROM - почтовый адрес отправителя уведомлений по EMail (адрес голосового сервера)

· MAIL_DATA - сообщение для уведомления. Текст почтового (EMail) сообщения.